Unable to delete object with Cardinality:Many on reference-property

I created an object class “Requisition” and an object class “Requisition Line”.

Requisition has a property of type Requisition with cardinality “Many”.

When I tried to delete an object in the Requisition table, I got this error message:
I assumed after a while that the action was trying to delete Requisition Lines, but they did not exist in any data source so could not be deleted…?

After deleting all the referenced Requisition Lines, I was able to delete the original as expected.

The delete rule was set to “none”, but I think what is needed is an inverse delete rule determining what should happen to all the Requisition Lines when a Requisition is deleted in the case of many cardinality references.

Hello Øyvind,

I was initially able to recreate the issue in my environment by setting the deletion rule to none as you described.
But then I set it to delete constraint and back to none and the issue dissepeared. It might also have been because of a refresh. Does the issue still persist?


Hi Erik.

I temporarily solved the issue by first deleting all the referenced objects, like this:

Now, the action works as intended even if I disable the first node:

So for my specific case the issue has been solved.


Glad to hear that it worked out :smile:

However this still seems challenge-worthy, so I will register it internally.