Action not able to read App Variables

I have this weird issue where the action seems unable to read values from App Variables. This works in other circumstances. To test if it was only values that were changed within the same chain of actions, I created a dumb static string in App Variables which is set as “test” on create. This is also not printed in the console.


Hi @Lavrans, can you see in Dev Tools / App Data that the app variables have expected values? Have you tried logging the same variables in another action?

App variables have the expected values from the action as well as the dummy Test-variable. It also manages to read the app variables when run with a different set of action parameters.

Hi! Could you re-check this one today using the Console Log in the browser (CTRL+SHIFT+I) and check the log there as well? It could be
a) The logging is out-of-order in the Dev Tools (has been spotted)
b) The deployment of changes to actions has not restarted the deployment service (has been seen and should be improved in the upcoming version).

I got the same result today. The main issue is not that it cannot console log, but that it does not read values from app variables. Below the logging in the action is a critical if-check. This checks a value that is set as true in the Dev Tools, yet returns Condition is false in the action.

Everything is supposed to happened sequentially, and I have verified that the value is set as it is supposed to earlier.

Hi! Can you try to breakpoint just before that IF action node from the Dev tools? Then execute the action and step through the action. Check what that App Variable is just before the IF, at the IF and after the IF? It sound to me like it is either changed, OR it might be that 2 app variables with the same node name has been created (should not occur, but has happened historically)?

See example of step-by-step debugging in screenshot below.

I found the error, and it was a mistake on my part. I have been looking at the wrong action and what is happening is actually existing in a copy of the original action.

Thanks anyway for the help :smile: