App not loading

We are experiencing a problem with our app. On friday morning one of our apps suddenly stopped loading in dev preview. This error is shown in the console.

Our other app, which is utilizes the same database, is working without issues. How do we fix this?


Have you changed datatype on a property in the global data model recently? E.g. from string to an object class reference?

The client complains about an empty string stored in a property that is supposed to be an object id.

If so: try to locate that object using GraphQL, and delete it.

I guess this is the Dev environment. Changing such datatypes will be blocked (if property is in use) in the upcoming version.

Thanks for your reply. We have tried locating the empty string property using GraphQL without any luck, probably because we have little experience using it. Do you have tips for any prompt I can use in GraphQL to find the property?

I have also tried reading all objects into the app data of our other app, as an attempt to recreate the error, but that app is still working fine.

Hi! Can you send med the name of the solution in DM, and we’ll take a look in the logs to see if we can identify it. For DM, click my avatar and send a message :wink: @petter

1 Like