Mailgun bad request error

Im having some issues trying to set up mailgun in appfarm, i have followed the steps from the docs but for some reason i getting “bad request” errors. I have attempted to change the URL to check if its correct and when i do i get “not found” so i assume the URL is correct, i tried the same with the API key and got “unauthorized” so i also assume that this is correct.

Everything seems to be set up correctly, and i dont know how to proceed from here.

Are there any rules for what the default sender address can be?

The email domain is set up like this:
and the default sender is:


Looks like this might possibly be related to mailgun:
Can you try again once things are operational?


1 Like

Thank you, this might be the answer.

Ill keep the post up and confirm when they are back up

Seems like this was not the issue, i have two different mails where one of them is working and the other one gets bad request error.

The difference between the two are,

The one that gets an error has CC and attachments, and the content for the mail is different. I have tried to send without the attachments and the CC, and i still get the bad request error.

Are there any limitations to the content of the mail with Mailgun as sender instead of appfarm?

The one that gets an error has CC and attachments, and the content for the mail is different.

can you provide an example of how exactly you setup the Send Email action node for the failing example? I can try to reproduce it and debug what’s going on.


I believe the HTML message is the issue, but i am not sure why. It works fine when using appfarm as sender.


Just a guess / something to explore: Could it be that the “non-html” setting “Message (text)” is required for this custom mailgun account? Could your try just with a “Message (text)” (and no HTML) when using the custom mailgun account?

I tried using the Message text and i swapped the HTML message with something basic that does not use any variables. I still get the error.


Just to check: Point 5 in this guide (“Go back to mailgun…”): Do you have a green checkmark on your domain?

Yes, as i mentioned one of the emails we are sending is working as expected, and there are no differences except from what i have described above.

Sorry for the delay.

I’ve been able to reproduce this issue. Have you tried setting a text field, in addition to a html field?

(I get a similar error if I only set a HTML entry but don’t set a text field)

Still getting the error

Ok, this is odd. My suggest would be to than try to determine the most minimal scenario where this issue reproduces.

Can you try to re-create the action (save the current one as backup) - and determine exactly which field breaks it? I would suggest to start with static data (instead of functions), and see if you can reproduce the issue.

This way we’ll know where to start looking for the bug.

Slightly tedious work, but I think this might be the only way to figure out what’s going on!

Solved it,

The issue was with the “sender” field, where i did not have a valid email.

When i changed it to a valid email it works as expected.

Thank you for helping!

1 Like