Advanced filter in function doesn't preload used data

Hello appfarm

Sorry for that weird title , didn’t know how to explain it in one sentence

i think i found a small bug in appfarm

As i understood, appfarm loads only variable properties that you use in the app. ( for instance : if i’m not using “Command Date” variable in any container / filter / action. appfarm will optimise by not loading them on the app )

i found that it doesn’t take into consideration advanced filters ( Filters in a filter )

i actually have a function with a database that i filter by looking into another database that i filter too.

it seems that the variable that i’m filtering with is not loaded in the app ( i only use it here for this specific App )

in this example : i’m using “Order Line” Database . i’m looking if it exists in “Order Header” database that i also filter . The variable that i’m using only one time is “POS Origin”. this doesn’t worked because my app doesn"t load it and thinks that i’m never using it.

Hope i was clear.


Thanks! Looks like a bug (reproduced with the same result)! The Filtered selection as part of the filter editor is quite new, so I believe we’ve missed to add those filter dependencies to the evaluation of which properties to read for an App.

Workaround: Make sure that property is in use somewhere else in the App.

Thanks Kristian

that’s exactly what i did to resolve that !

enjoy your day !

1 Like