Error message when mapping result from web request


I have created a web request to an external datasource. When running the web request without result mapping I am receiving the response:

“requestConfig”: {
“url”: “####”,
“headers”: {
“server”: “####”,
“database”: “####”,
“subscription-key”: “####”,
“Authorization”: “####”,
“responseData”: {
“status”: 200,
“statusText”: “OK”,
“rawData”: [
“prosjekt_tx”: “Lorem ipsum”,
“prosjekt_fx”: “12345”,
“id”: 15
“prosjekt_tx”: “Lorem ipsum 2”,
“prosjekt_fx”: “6789”,
“id”: 16

I then tried to map the result to a object class:

But then I am getting the error message “non-integer path for Array”:

I have tried quite a few possibilities, but not able to return the right mapping.

Anyone have seed this before and can guide me in the right diretion?



Could you try without the “rawData” root path? i.e. leave the root path blank. I believe the log you see in the debug info has a bit more (the debug info, containing the configuration of the web request and more, is a JSON as well). The actual response is actually only what your see inside the rawData. In other words, I believe the JSON you receive is
“prosjekt_tx”: “…”,



Thanks for the clarification, Kristian. It worked!