Expected integer got number

Hello Appfarm

i’m having problem manipulating service variable in Appfarm Service

the context :

  • i’m calling a service that makes movement on stock. i send to this services some data that i store either in a data or in a service variable
  • for some of the param. there is cases that i don’t need to send all of them ( just considering that they’re null ( in that case it’s the " incremental ID - Fusion " that we will follow and that i try to put in a service variable )
  • if i execute it. i’ll receive an error that looks like this
    Looking to my service logger i’ll have this

if i remember, this process was almost working last year :

  • i found a workaround , wich force to update my value to “null” when it comes null in the call ( sounds weird but it worked )

i tried :

  • sending my value empty
  • sending my value by putting “Null
  • try to force the “Null” part in my service

if i do a simple test like this. Appfarm thinks that there is a value in this variable.
and will show this custome message that i wrote for each case (“NaN” is my variable that i try to show . FYI i never changed or touched my value in this process. it should be just empty )

i just found another workaround :

  • change my “Null” check to this

P.S : i found the same problem in another service that was working fine

sorry for that long message.

Cheers :v:

Apologies for the belated response.

Did the isNaN-workaround solve the issue? If so, is the field Incremental ID ever set to anything calculated from external data? We have seen a few cases where calculations in external data caused function evaluations to result in NaN, so it would be good to rule that out first.

Hey timkurvers

the Incremental ID was never set or touched before. just going empty in it ( in this process )

also yes. the isNaN workaround solved it