ResourceNotFoundError: Unable to find dataSource

Hey, I’m making a service where we call an external API and iterate the responses from it.

I have made a runtime data-source of my responses. I want to iterate it and select the object in context, but I get the error in the attached image.

This iteration is encapsulated by two iterating data-sources, so it is on level 3 of a nested iteration. Could this be the reason?


I’ve tried investigating this further, but I still can’t find a logic answer to the issue. I’ve now changed the logic so that I add all responses to a data source so that I can iterate over them at the end of the action, outside the previous iterations.

I still get the same error, and even when trying to read a different data source and select context there does not work. The action nodes in the image now also give me the resource not found error.

Any idea what’s causing this?


Thank you for reporting this to the Community :smile:

I was able to replicate your issue with 2 levels of nested iterations and a set selection.
I have registered a challenge for the bug, as the number of iterations should not affect Set Selection.

// Erik