Runtime in context error


I have a list of runtime objects iterated in a list, and I have an action on each iteration which should select the runtime object in context. However, there is no object in the context data when I run the action.

Is this expected behavior?


Skjermbilde 2024-01-09 kl. 15.49.45

Hi Petter,

Can you share some more information about the configuration of the iterating container?
A screenshot of the event handler, the container it is connected to and the action that is ran when clicked would be nice :slight_smile:

I am unable to replicate your issue, the object in context is selected when clicked on my machine.

Not sure if it is relevant.

But today I encounter a similar issue, where a an action was triggered from a table, reading data from context. The log reported that no context was found, with red error, but it worked. It appeared that the same action was also connected to the “On view load” event handler of the view to be opened, where there is no context (and the log entry we actually saw was the one when the action was executed from on view load, and not on click from table).

Sure, here are some pictures, but I just found the cause:

My list should disappear after a list element has been selected. I hide the list by using a boolean and a visibility condition. When I removed this and made the list stay visible after selecting an element, the action worked as expected.

So I guess there is a bug where the context is not registered if the element it is connected to becomes invisible.

Skjermbilde 2024-01-10 kl. 15.57.57