Dev environment not able to load

Good morning!

We are currently struggling to access our dev application. The other environments works fine.

Error message:
getDataFromDataValue: dataValue.type

We’ve tried to delete the newly created items right before we received the error message, but hasn’t worked. Anyone that can help us? :slight_smile:

Hey Tuva! We’ve just restarted your services. Could you try to reload in a couple of minutes and let us know if the issue is resolved?

1 Like

Hi, Johanna.

The issue is resolved. Thank you for your help!

Is there anything we can do next time this happens, or do we need to create a community post again?

Hello, we have received the same error again. Is there a reason to why we receive these error messages, if so, what can we do to prevent them?

Also, if can you restart our services again?

Please and thank you.

Hi, we are sorry for the inconvenience. We are currently investigating this error.
If you can access to DevTools, could you please click the SEND CLIENT STATE button, so that we can gather some more information about the error?

If not, could you please add me ( to the solution so I can gather the info about the error we need?

We will of course restart services as soon as we have the info we need about the error.

Hi Olav.

Thank you for your reply.

We have created a user for you as we don’t have access to the DevTools. The application we’re experiencing issues with is: Helseplattformen - Pasient.

Thank you for your help!

1 Like

Thank you very much!

We have now gathered the info we needed, which will hopefully help us resolve the issue.

Services have been restarted.

1 Like

Thank you for your help, Olav!

Hello - i am working with Tuva on this project. The same issue is occuring again, same error message. I tried to remove all test data this time, but no difference. Could you maybe reset the services again? :smiley:

Sorry for late reply on this one. Services were restarted now, is the issue solved?

Hello Kristian. Thank you for restarting our service - it works now! Can we ask why this keeps happening, and what we can do to prevent it from happening again or perhaps less frequent?

Look forward to your reply.

Yes, it is a special case that is under investigation. We’ll keep you posted when we have pinpointed it, and until then, let us know if the problem arises (you may also use email or slack if you have a point of contact)

1 Like

We have now pinpointed the issue. This is a corner case where it can happen when timers are defined on an app, and changes are made to data sources and app settings within a few seconds. It does not have to be the same user doing the two changes, so this is seen more often in solutions where multiple developers are active simultaneously.

A fix for this issue is ready and will be rolled out in a patch tomorrow.


Thank you for your help and for explaining the issue. Hope you have a great day!