Unauthenticated access still require login


We have created a new app and implemented unauthenticated access for it, all steps according to Configure unauthenticated access - Appfarm Documentation

  1. Created a new role and granted access to Dev/Stage/Prod environments
  2. Under permissions gave access to the new role access to the newly created app and required object classes
  3. Under service accounts created a new account and assigned it with a unauthenticated role.
  4. Under environments - Application security - enabled unauthenticated access for the created service

But when we are trying to access the app, we still see a login prompt, so it’s not possible to access it without authentication.

Solution name is Zenfinans

Hi! The fist time unauthenticated access is enabled for any App in an environment, there might be a minor delay. Could you check if it works now already? You should try the link in incognito mode as well to check that it is not your logged in credensials that stops you from accessing it (if you are logged in, only being a member of Role A, then Role A also needs access to that unauthenticated App if you should be able to access it while logged in).

thank you, it took couple of hours, but now it works